Friday, April 9, 2010

Konfigurasi VLAN - VTP menggunakan Cisco Packet Tracer

VTP (VLAN Trunk Protocol) adalah Cisco proprietary Layer 2 protocol yang mengatur penambahan, pengurangan, dan penamaan dari VLAN, jadi ketika ada VLAN baru yang dikonfigurasi pada salah satu VTP Server, VLAN tersebut akan langsung didistribusikan melalui trunk link ke semua switch yang terhubung dengan VTP Server.

Keuntungan dari VTP ini adalah, kita tidak perlu mengkonfigurasi VLAN pada setiap switch, hanya tinggal meng-assign port-port masuk ke VLAN, jadi kita bisa menghemat waktu konfigurasi, hehe

Nah ! langsung saja saya menjelaskan bagaimana cara mengkonfigurasi VTP pada Switch Cisco.





















Skema IP :
VLAN 2 :
IP Network : 192.168.2.0./24
IP Host : 192.168.2.2-255

VLAN 3 :
IP Network : 192.168.3.0/24
IP Host : 192.168.3.2-255

Router 0
konfigurasikan subinterface pada fa 0/0
subinterface fa0/0.2 = ip 192.168.2.1/24
subinterface fa0/0.3 = ip 192.168.3.1/24

Switch 0
konfigurasikan port fa0/1 sampai fa0/3 sebagai trunk link
hubungkan fa0/4 ke hub VLAN 2
hubungkan fa0/5 ke hub VLAN 3
konfigurasi VTP server, domain, dan password ( antara Server dan Client, domain dan password harus sama, yang hanya berbeda mode saja )

Switch 1 dan Switch 2

konfigurasikan port fa0/1 sebagai trunk link
hubungkan fa0/2 ke hub VLAN 2
hubungkan fa0/3 ke hub VLAN 3
konfigurasi VTP client, domain, dan password

( hubungkan antar Switch menggunakan kabel Cross dan menggunakan Port yang berfungsi sebagai Trunk link, seperti skema jaringan diatas )


Konfigurasi Router 0

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa0/0
Router(config-if)#no shut
Router(config-if)#ex

Router(config)#interface fa0/0.2
Router(config-subif)#encapsulation dot1Q 2
Router(config-subif)#ip address 192.168.2.1 255.255.255.0
Router(config-subif)#ex

Router(config)#interface fa0/0.3
Router(config-subif)#encapsulation dot1Q 3
Router(config-subif)#ip address 192.168.3.1 255.255.255.0
Router(config-subif)#ex

 
Router(config)#



1. Pastikan anda mengkonfigurasi VTP Server dan Client sebelum menambahkan VLAN


Konfigurasi Switch 0 - VTP Server
Switch>en
Switch#conf t
Switch(config)#vtp mode server
Switch(config)#vtp domain smk3
Switch(config)#vtp password smk3

 
Switch(config)#interface range fa0/1 - 3
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#ex





Konfigurasi Switch 1 dan Switch 2 - VTP Client
Switch#en
Switch#conf t
Switch(config)#vtp mode client
Switch(config)#vtp domain smk3
Switch(config)#vtp password smk3
Switch(config)#ex
Switch#

Switch(config)#interface range fa0/1 
Switch(config-if)#switchport mode trunk

2. Pastikan VTP Server dengan Client sudah terkoneksi pada Switch 0, Switch 1 dan Switch 2
Switch#show vtp status

VTP Version                                : 2
Configuration Revision                 : 0
Maximum VLANs supported locally : 255
Number of existing VLANs             : 5
VTP Operating Mode                    : Server
VTP Domain Name                       : smk3
VTP Pruning Mode                        : Disabled
VTP V2 Mode                               : Disabled
VTP Traps Generation                   : Disabled
MD5 digest                                  : 0xA2 0x01 0xEE 0x53 0x0C 0x7C 0x75 0x0C
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)
Switch#


diatas adalah konfigurasi VTP pada Switch 0, karena Switch 0 bekerja sebagai Server
perbedaanya pada Switch 1 dan Switch 2 adalah pada Operating Mode bekerja sebagai Client, 
jika Number of existing VLANs berjumlah sama pada ketiga switch tersebut, maka VTP sudah bekerja.


3. Menambahkan VLAN pada Switch 0

Konfigurasi VLAN 3
Switch(config)#vlan 3
Switch(config-vlan)#name Administrasi
Switch(config-vlan)#ex

Konfigurasi VLAN 4
Switch(config)#vlan 4
Switch(config-vlan)#name Lab.Jaringan
Switch(config-vlan)#ex


untuk memeriksa apakah VLAN sudah terdistribusi oleh Switch 0 gunakan perintah ini pada Switch 0, Switch 1, dan Switch 2
Switch#show vlan


VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                              active    Fa0/4, Fa0/5, Fa0/6, Fa0/7
                                                           Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                           Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                           Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                           Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                           Fa0/24, Gig1/1, Gig1/2
2    Admin                                active   
3    Lab                                    active   
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0  
1003 tr    101003     1500  -      -      -        -    -        0      0  
1004 fdnet 101004     1500  -      -      -        ieee -        0      0  
1005 trnet 101005     1500  -      -      -        ibm  -        0      0  

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
Switch#


jika pada Switch 1 dan 2 sudah sama seperti diatas, maka VLAN sudah berhasil didistribusikan tinggal memasukan port-port kedalam VLAN

4. Konfigurasi VLAN pada Switch 0
Switch(config)#interface fa0/4 - hubungkan Daerah VLAN 2 ke port fa0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 2
Switch(config-if)#ex


Switch(config)#interface fa0/5 - hubungkan Daerah VLAN 3 ke port fa0/5
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 3
Switch(config-if)#ex
Switch(config)#
5. Konfigurasi VLAN pada Switch 1 dan Switch 2


Switch(config)#interface fa0/2 - hubungkan Hub VLAN 2 ke port fa0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 2

Switch(config-if)#ex
Switch(config)#interface fastEthernet0/3
- hubungkan Hub VLAN 3 ke port fa0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 3
Switch(config-if)#ex


tahap terakhir ini, anda tinggal menambahkan PC ke setiap VLAN, menuliskan alamat IP pada setiap PC,
lalu testing ping ke gateway. Jika sudah berhasil, anda tes ping ke PC di VLAN lain .


jika menemukan masalah, anda bisa add YM saya : bogor_pdn, atau mengisi pada komentar
semoga membantu dan selamat mecoba .. :) ..
Get Chitika | Premium

2 comments:

ahmed said...

thanks gan artikelnya untuk belajar..
mampir jg ya k http://jaketkuning.unsri.ac.id/ahmed/blog/819/

Anonymous said...

good information,thanxs

just share

Post a Comment

/nobigdeal /hihi /wahaha /omg /no /dignose /sweat /sweat /shock /floor /XD /hmm /blur /blush /bye /please

DB27JHW8S88T